Android is in Alpha!


Great news Android users, the GOFAR app is in alpha!


This is the very minimal GOFAR Android app. It will let you set up your GOFAR account, set up your dongle and Ray and will log your trips.

We will continually release updates as we add in more functionality. Please be patient, it will happen eventually :)

= Known Issues =
– Bluetooth Flakiness (try killing app, turning bluetooth off and on)
– No server sync (data will exist only on the phone)
– No location services
– Slow firmware update
– No Driving Summary & Scores
– No Detailed trip information
– No Localised Units
– No Brightness Setting


2 people like this

Hello,


Is there a forum where you want us to report back? 
I plugged it into the car, went to Bluetooth settings, found it, paired it. But it doesn't seem to want to connect with it. 

In the attached screenshot you see I have 3 devices, the car, my watch and Ray. When I click on the car, it connects to the car, when I click on the watch it tries to connect to it (I didn't have it on me, it was turned off) but when I click on DIDErr nothing is happening. 

Within the app. I keep clicking connect, and retry and nothing is happening either. 


Hi Janos,


All connecting and pairing should take place inside the app. If you've connected in the Settings, please disconnect and "Forget" the peripheral and power cycle the phone.


Then, please go through the vehicle setup steps in the app and let me know which of the following steps you get stuck on:


1 - "Plug GOFAR then connect"

2 - "Scanning for GOFAR"

3 - "Connecting"

4 - "Sending PIN"

5 - "Connected!"

6 - "Start Engine then press Connect"

7 - "Connecting to vehicle"

8 - "Configuring vehicle"

9 - "Completing Setup"

10 - "Encrypting connection"


Also, when you get stuck, what colour is on the dongle?

1. Blue.

2. Green

3. Yellow

(unfortunately green and yellow look very similar)


Thanks,


Pete

I tried it, still no luck,


Now you said 1. "Plug GOFAR then connect"
What does that mean? Because according to your steps GOFAR remains powerless until step 6 "Start Engine". So how would a powerless GOFAR connect to anything?
So what I did was:

- Connect the sensor into the car, then using the cable connected it to the Ray.
- Turned the car on

- Open the app

- Set Up Vehicle

- Enter PIN

- Connect
Then nothing happened, kept the retry button appear.

Dongle was blue

Attached are the steps in order.

As I said earlier I also tried to go to phone's settings, bluetooth, and connect to DIDErr.

Which you replied it should only be done through the app so I had bluetooth "forget" it. Restarted phone and tried it like that. No luck.



ray.jpg
(243 KB)


Ok thanks for all that information.


I just released an update that I hope will fix the issue. Please let me know if it does or does not.


Thanks!


Pete

I can get it to connect, but it says "Updating firmware (est. 20 minutes)" it just sits there and never does anything.

I was able to complete the connection,

then it took 20 minutes to update firmware,

And logged 3 trip

Now I know this is beta, but just letting you know I can't click on anything else under the Home panel,

can't view, or delete trips already logged.

Under the Settings panel I can't click settings, only log out.

On the Ray itself,

Is it supposed to be half green and half purple-ish?

I'll go for another drive in about 2 hours we'll see how it behaves then.

I went for another drive, the first ride the Ray was only blue, but it was getting lighter then darker then lighter then darker then lighter.........

I don't think it registered the ride cause it didn't show up in the app.

On the way back it was mostly blue (or green I don't remember anymore) but it was turning red when I was accelerating.

 I also noticed if I try to turn the app on without having Bluetooth enabled it tells me: "Unfortunately, GOFAR hs stopped."


Hi all,


I released an update yesterday. If you are having trouble please try the following:

  • Uninstall the GOFAR app
  • Install the latest version 0.1.3
  • Sign in
  • Redo setup (if firmware was already updated, this won't need to be redone)
  • Go for a drive... The Ray should be white and as you drive around gradually turn green as it calibrates to your car
Good Luck!

Took a littler harder to connect this time but got it done.

I may by confused on how the Ray supposed to work.
It was white, then turned green, then keeps getting lighter and darker green like its breathing. Is that what it's supposed to be doing?

I have installed the latest version. Everything connects, firmware updated. It connects to vehicle then says that it is saving the vehicle to the cloud but after about 10-15 seconds it stops and says connection failed. I have tried with WiFi in my driveway, and with full LTE connection with the same results.

Zach can you please try signing out and signing in to your user account? Obviously you should not have to do this but it seems to be a workaround a few people are using. We are fixing this issue as a priority.


I noticed you have installed the app on two devices, do you have the same problem on both?

I was trying it on my Nexus 6 and having the problem, I tried this morning on my S5 and it seems to be working.

I have finally made it through the calibration and the visual indicator is working again.  However, the app does not seem to be registering my trips.  Should it update in real-time?  When I finish a trip?  The next time I get in my truck?


Also, I have found that if I kill the app (or don't use it for awhile so that it is no longer in memory, I am at the start screen with an option to Buy Now, Set up Vehicle or Sign Out.  If I try the set up vehicle option, I have to go through the setup wizard which eventually fails when trying to save to the cloud.  The only option that seems to work to get back into the app is to sign out and then sign in again.


I did confirm that Location permission was already granted, but I did have to enable storage permission - however, I have not noticed a change in behavior after doing so.

Login or Signup to post a comment