Start a new topic

Cannot upgrade to firmware 4.0.17.0

The GoFar App is showing a firmware update as being available - but every time I've tried to apply it (and I must have tried at least six times now...) the process has hung with the App saying "Installing" with a spinner on-screen. If I select "Cancel" then further attempts to upgrade result in a "Ensure Bluetooth is on and wait for 20 seconds" message until the dongle is removed from the vehicle and re-inserted. When attempting an upgrade, the dongle flashes blue for a few tens of seconds, then shows solid green (reboot?), and then stays dark. I currently have firmware 4.0.16.4 (from memory - I successfully upgraded to the previous release). Again, much more visibility in the App would be welcome here - tell us whether the App is downloading a new firmware image, programming blocks, waiting for a reboot, switching firmware banks, etc. In the meantime, any thoughts on why the firmware update is repeatedly failing, and what Ican do about it?


Hi Stuart,


Could you please try to perform the update with the engine running?


Thanks,


GOFAR

That seems to have done it! Despite immediately detecting the start of a trip, I still git the "wait 20 seconds" message - but after doing so I was able to install the update. Odd thing, the Upgrade Firmware dialog immediately disappeared without having been cancelled, meaning that I had to check Advanced Settings after the dongle rebooted to check the firmware version was updated. Any thoughts on the cause? Should I leave my engine running for future updates? Cheers, Stuart
* got ;) Autocorrect...
Login or Signup to post a comment